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Lesson 13 Patterns and Weldments 
 

 
Figure 13.1 Mounting System Weldment 
 
OBJECTIVES 

 
 Create directional patterns 
 Create dimensional patterns 
 Pattern components on an assembly 
 Insert multiple standard parts using a reference pattern 
 Use fill to pattern a feature 
 Insert welds on a model 

 
REFERENCES AND RESOURCES  
 
For Resources go to www.cad-resources.com > click on the Creo Parametric Book cover 
 

 Lesson 13 Lecture  
 Book Projects PDF  
 Project Lectures  
 Creo Parametric Quick Reference Card  

http://www.cad-resources.com/Creo_Parametric_Qick_reference_cards.pdf  
 Creo Parametric Configuration Options  

http://www.cad-resources.com/Creo_1.0_configoptions.pdf  
 
Patterns and Weldments 
 
Creating a pattern is a quick way to reproduce a feature, or a component in an assembly (Fig. 13.1). A 
pattern is parametrically controlled. Therefore, you can modify a pattern by changing pattern parameters, 
such as the number of instances, spacing between instances, and original feature dimensions. Modifying 
patterns is more efficient than modifying individual features. In a pattern, when you change dimensions of 
the original feature, Creo Parametric automatically updates the whole pattern. This lesson will introduce you 
to variations of the Pattern Tool, and introduce the Welding application. 
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Mounting Bracket 
 

For Lessons 13-18, step-by-step commands are limited to new software commands introduced or enhanced 
in that lesson. You are expected to do most of the modeling using commands and practices mastered from 
Lessons 1-12 without repeated detailed explanations. Refer to Figures 13.2(a-f) for the Bracket dimensions. 
 

 
Figure 13.2(a) Mounting Bracket  
 

  
Figure 13.2(b) Mounting Bracket Detail   
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Figure 13.2(c) Mounting Bracket Front View  
 

 
Figure 13.2(d) Mounting Bracket Right Side View  
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Figure 13.2(e) Mounting Bracket Top View  
 

 
Figure 13.2(f) Detail View A   
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Steps 
 

Start a new part. Press: Ctrl+N > mounting_bracket > OK > File > Prepare > Model Properties > Units 

change >  > Close > Close >  > in the Graphics Window, 

press RMB > Define Internal Sketch > select the FRONT datum plane > Sketch >  > sketch the L-

shaped section [Fig. 13.3(a)] >  > modify the length to 12 > Ctrl+D [Fig. 13.3(b)] >  >  > OK 
 

  
Figure 13.3(a) Sketch the L-shaped Section  
 

  
Figure 13.3(b) Mounting Bracket will be 12.00 in Length  
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Click:  >  >  >  > select the FRONT datum plane > double-click in the 

Offset Translation field > 2.00 [Fig. 13.3(c)] > Enter > OK >  Resumes the previously paused tool > 

 > sketch the three lines of the open section [Fig. 13.3(d)] > Ctrl+D >  [Fig. 13.3(e)] > in the 
Graphics Window, double-click on the rib thickness and modify to 0.5 > Enter > Enter > Ctrl+S > OK  
 

 
Figure 13.3(c) Offset Datum Plane (Note that you can also double-click on the value in the Graphics Window)  
 

 
Figure 13.3(d) Open Section for the Rib (Note the Reference Lines)   
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Figure 13.3(e) Rib Preview  
 

With the rib still selected, press: RMB > Pattern >  > Dimension > Dimensions tab > in the Graphics 

Window, select 2.00 > type 4.00 > Enter > 1 item(s), type 3 > Enter [Fig. 13.3(f)] >  > Ctrl+S > OK  
 

 
Figure 13.3(f) Dimensional Pattern   
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Click:  > create the hole as per the Placement and Shape requirements [Figs. 13.3(g-h)] >   
 

 
Figure 13.3(g) Hole Placement  
 

 
Figure 13.3(h) Hole Shape   



Creo Parametric  Lesson 13 

©	2013	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 591

 

With the new hole still selected (highlighted), press: RMB > Pattern >  > Direction > 

 > remove the 

inner two pattern instances  [Fig. 13.3(i)] >  [Fig. 13.3(j)] > Ctrl+S > OK  
 

 
Figure 13.3(i) Directional Pattern  
 

 
Figure 13.3(j) Counterbore Hole Pattern   
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Click:  > add the.500-13 hole, located per the Placement and Shape requirements [Figs. 13.3(k-l)] 

>  > Ctrl+S > OK  
 

 
Figure 13.3(k) 7.00 from Datum FRONT and 2.00 from Datum TOP  
 

 
Figure 13.3(l) Shape of .500-13 Hole   
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With the new hole still selected (highlighted), press: RMB > Pattern >  > Fill > References tab > Define 

> select the left face of the part > Sketch >  >  Offset > Loop > select the left face > -.3875 [Fig. 

13.3(m)] > Enter [Fig. 13.3(n)] > Close >  > Sets the spacing between pattern member centers, type 1.00 

> Enter >   
 

 
Figure 13.3(m) Offset -.3875  
 

  
Figure 13.3(n) Offset Loop   
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Click:  to toggle off the unwanted instances [Fig. 13.3(o)] > spin the part [Fig. 13.3(p)] >   
 

 
Figure 13.3(o) Toggle Off Unwanted Instances of the Pattern  
 

 
Figure 13.3(p) Pattern Preview   
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Click: Applications tab >  >  all off > LMB in the Graphics Window >  >  >  

 > Location tab > select the surface as Side 1 
[Fig. 13.3(q)] > press RMB > Side 2  
 

 
Figure 13.3(q) Select Side 1 of the Weld   
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Press and hold the Ctrl key and select the vertical surfaces of the ribs [Fig. 13.3(r)] > release the Ctrl key > 
press RMB > New Set 
 

 
Figure 13.3(r) All Vertical Surfaces for Side 2 of the Weld   
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Press: RMB > Side 1 > select the vertical surface as Side 1 [Fig. 13.3(s)] > press RMB > Side 2  
 

 
Figure 13.3(s) Select Side 1 of Set 2 Weld Sets   
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Press and hold the Ctrl key and select the surfaces of the ribs > release the Ctrl key >  on [Fig. 13.3(t)] > 

 >   
 

If you select the wrong item, place the pointer over the item in the appropriate dialog box > press RMB > 
remove.  
 

 
Figure 13.3(t) Select the Surfaces for Side 2 of the Weld Set 2   



Creo Parametric  Lesson 13 

©	2013	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 599

 

Click:  [Fig. 13.3(u)] > Ctrl+S > OK > File > Manage File > Delete Old Versions > Enter > File > 

Save As > Type >  > Zip File (*.zip) (scroll to the end of list) > OK > upload the zip file to your course 
interface or attach to an email and send to your instructor and/or yourself > File > Close  
 

 
Figure 13.3(u) Completed Fillet Weld  
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Base Plate 
 

 
Figure 13.4(a) Base Plate  
 

   
Figure 13.4(b) Base Plate Detail   
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Press: Ctrl+N > base_plate > OK > File > Options > Customize Ribbon > Import/Export > Import 

customization file > select your previously saved .ui file from Lesson 2 ( ) > 
Open > Import Mode Customizations > Configuration Editor > Import/Export > Import configuration 

file > select your previously saved file from Lesson 2 (CREO_textbook.pro) > Open > OK > No >  

>  all on > select the TOP datum plane >  >  > add vertical and horizontal 

centerlines > sketch the rectangular section [Fig. 13.5(a)] >  > Standard Orientation >  > modify 

the depth to 1.50 inches [Fig. 13.5(b)] > Enter >  > Ctrl+S > OK 
 

  
Figure 13.5(a) Sketch the Rectangular-shaped Section  
 

 

 
Figure 13.5(b) Depth of 1.50   



Creo Parametric  Lesson 13 

©	2013	Cengage	Learning.	All	Rights	Reserved.	May	not	be	scanned,	copied	or	duplicated,	or	posted	to	a	publicly	accessible	website,	in	whole	or	in	part. 602

 

Click:  > create the hole as per the Placement and Shape requirements [Figs. 13.5(c-e)] > 

 > 

 >  > OK 
 

 
Figure 13.5(c) 1.00 Diameter Hole  
 

                 
Figure 13.5(d) Hole Placement                                    Figure 13.5(e) Hole Shape   
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With the hole still selected (highlighted), press: RMB > Pattern [Fig. 13.5(f)] >  > Direction > select two 

reference direction surfaces [Fig. 13.5(g)] >  > Ctrl+S > OK > Annotate tab > select the features in the 

Model Tree > Show Annotations >  tab >  > Apply > Cancel > pick on a dimension > press RMB > 
Move > pick a new position > reposition remaining dimensions as required > LMB to deselect > Model tab  
 

 
Figure 13.5(f) Pattern 
 

 
Figure 13.5(g) Pattern Preview (Enter Negative Spacing Values if Required)   
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Click:  >  > select the 1.00 diameter dimension > press 

RMB > Properties > Display tab >  [Fig. 13.5(h)] > Move > pick a new position > OK [Fig. 
13.5(i)] > LMB > Ctrl+D > Ctrl+S > OK > File > Save As > Type > Zip File (*.zip) > OK > upload to 
your course interface or attach to an email and send to your instructor and/or yourself > File > Close  
 

 
Figure 13.5(h) Dimension Properties 
 

 
Figure 13.5(i) Edited Dimension Note (Your Note Orientation May Be Different)   
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Mounting System Assembly 
 

 
Figure 13.6(a) Mounting System Assembly 
 

 
Figure 13.6(b) Mounting System Assembly Exploded 
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Figure 13.6(c) Placement Location Dimensions 
 

 
Figure 13.6(d) Placement Location in the Assembly Model   
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Click:  >  > mounting_system > OK >  > base_plate > Open > press 

RMB > Default Constraint >  >  > mounting_bracket > Preview > Open > use the 3D 
Dragger to initially orient and position the component > Placement tab > first constraint set [Fig. 13.7(a)]  
 

  
Figure 13.7(a) Distance Offset 1.50 (Enter a Negative Value if Required)   
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Press: RMB > New Constraint > second constraint set [Fig. 13.7(b)]  
 

 
Figure 13.7(b) Distance Offset 3.00 (Enter a Negative Value if Required)   
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Press: RMB > New Constraint > third constraint set [Fig. 13.7(c)] >  > Ctrl+S > OK  
 

 
Figure 13.7(c) Coincident (Use your RMB and click through the features and select the bottom face of the Mounting Bracket) 
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Click:  >  on (all others off) > LMB in the Graphics Window > from the Model Tree, 

 > RMB > Activate >  >  >  >  > Placement tab > select the 
axis of the counterbore hole [Fig. 13.8(a)] > hold down the Ctrl key > select the top surface of the base plate 

[Fig. 13.8(b)] > release the Ctrl key >   
 

 
Figure 13.8(a) Select the Counterbore Hole Axis on the Mounting Bracket 
 

 
Figure 13.8(b) Select the Counterbore Hole Bearing Surface on the Mounting Bracket   
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With the new hole still selected, press: RMB > Pattern >  > Reference [Fig. 13.8(c)] >  [Fig. 13.8(d)] 
 

 
Figure 13.8(c) Pattern Preview 
 

 
Figure 13.8(d) Completed Pattern   
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Click:  open browser panel >  >  > ANSI ENGLISH [Fig. 

13.9(a)] > scroll to the bottom >  [Fig. 13.12(b)]  
 

 
Figure 13.9(a) 3DModelSpace 
 

 

 
Figure 13.9(b) Accept the Terms   
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Click: SOCKET CAP-SHOULDER- SET SCREWS [Fig. 13.9(c)] > HEXAGON SOCKET HEAD CAP 
SCREWS [Fig. 13.9(d)]  
 

 
Figure 13.9(c) ENG-PART LIBRARY 
 

 
Figure 13.9(d) Hexagon Socket Head Cap Screws   
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Click: Nominal Size [Fig. 13.9(e)] > 0.500 > Length > 1.500 [Fig. 13.9(f)] > Product Number CSDD401  
 

 
Figure 13.9(e) Product Number 
 

 
Figure 13.9(f) CSDD401   
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Click: Choose Format > Creo Parametric Wildfire2.0 or later (.prt) [or Educational Models] [Fig. 
13.9(g)] > Download 3D Model > here > Open > Extract > select your working directory > complete the 

steps to unzip the file > close your zip and folder windows >  close the browser > from the Model Tree, 
MOUNTING_SYSTEM.ASM > RMB > Activate > Assemble > csdd.prt > Folder Tree [Fig. 13.9(h)]  
 

 
Figure 13.9(g) Hexagon 
 

 
Figure 13.9(h) csdd.prt   
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Click: Open > [Fig. 13.9(i)] > By Column tab > BASIC_ DIA > 0.5 [Fig. 13.9(j)] > d4, L > 1.500000 [Fig. 
13.9(k)] > Open > if needed - select Close (from the Auto Place dialog box) > using your RMB, click 
through the features and select the BASE_PLATE:Surf:F14(HOLE_2_1_1) [Fig. 13.9(l)]  
 

       
Figure 13.9(i) Select Instance       Figure 13.9(j) BASIC_DIA; 0.5                      Figure 13.9(k) d4, L; 1.500000  
 

 
Figure 13.9(l) Select the Base Plate Hole’s Surface (Your Feature Name May Be Different)  
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Click: Placement tab > place your pointer on the blue ball of the 3D Dragger > press the LMB and move the 
component up > release the LMB [Fig. 13.9(m)]  
 

 
Figure 13.9(m) Using the 3D Dragger, Move the Component Away from the Hole   
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Select the MOUNTING_BRACKET:Surf:F12(HOLE_1_1_1) of the bearing surface of the counterbore 
hole [Fig. 13.9(n)]  
 

 
Figure 13.9(n) Select the Counterbore Hole’s Bearing Surface   
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Socket head cap screw is now Fully Constrained [Fig. 13.9(o)]. Click:  [Fig. 13.9(p)]  
 

 
Figure 13.9(o) Fully Constrained Component 
 

 
Figure 13.9(p) Placed Component (Note that the Socket Head Cap Screw had a predefined Component Interface)  
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With the screw still selected (highlighted) [if not, select the component from the Graphics Window or Model 

Tree], press: RMB > Pattern > Reference is the default since the hole’s were patterned [Fig. 13.9(q)] >  
[Fig. 13.9(r)] > LMB to deselect  
 

 
Figure 13.9(q) Patterning the Component 
 

 
Figure 13.9(r) Patterned Component 
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In the Model Tree; using the Ctrl key, select the Mounting Bracket and the CSDD pattern > with the pointer 
within the Model Tree, RMB > Group [Fig. 13.10(a)]  
 

 
Figure 13.10(a) Group 
 

The Group failed because of external references used to place the socket head cap screw. Note the message 
area located below the Graphics Window (if needed- expand the message area) [your feat id # may be 

different]  
> LMB to deselect > select the first instance of the screw pattern > press RMB > Edit Definition [Fig. 
13.10(b)]  
 

 
Figure 13.10(b) Edit Definition   
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Click:  Place manually > Placement tab >  (your Set # may be different) > RMB > 
Delete [Fig. 13.10(c)] > move the component using the 3D Dragger [Fig. 13.10(d)]  
 

 
Figure 13.10(c) Delete INTFC001 
 

 
Figure 13.10(d) Move the Component Using the 3D Dragger   
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Click: LMB on the (shaft) surface of the socket head cap screw to select it [Fig. 13.10(e)] > select the 
counterbore hole’s surface [Fig. 13.10(f)]  
 

 
Figure 13.10(e) Select the Shaft of the Screw and the Hole’s Surface 
 

 
Figure 13.10(f) Coincident Constraint   
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Press: RMB > New Constraint > select the bearing surface of the socket head cap screw [Fig. 13.10(g)] > 

select the counterbore hole’s bearing surface [Fig. 13.10(h)] >  >  >  [Fig. 
13.10(i)]  
 

        
Figure 13.10(g) Select the Screw Bearing Surface      Figure 13.10(h) Select the Counterbore Hole Bearing Surface  
 

 
Figure 13.10(i) Fully Constrained Component   
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In the Model Tree; using the Ctrl key, select the Mounting Bracket and the CSDD pattern > RMB > Group 

[Fig. 13.11(a)] > press RMB > Pattern [Fig. 13.11(b)] >  >  on > LMB in the 
Graphics Window  
 

 
Figure 13.11(a) Group the Mounting Bracket and the Patterned Screws 
 

 
Figure 13.11(b) Pattern the Group   
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Click:  >  > select the end surface as the direction reference [Fig. 13.11(c)] > flip the direction 

arrow >  instances >  spacing > Enter >  >  Regenerate >  > Standard 
Orientation [Fig. 13.11(d)] > Ctrl+S > OK  
 

 
Figure 13.11(c) Two Instances Spaced 22.00 Apart 
 

 
Figure 13.11(d) Completed Mounting System Assembly   
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Click: Tools tab > Reference Viewer >  [Fig. 13.12(a)] > Close > Bill of Materials > Top 

Level > OK [Fig. 13.12(b)] >  close the Browser  
 

 
Figure 13.12(a) Reference Viewer 
 

 
Figure 13.12(b) BOM 
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Click: View tab > Model Display Group > Temporary Shade [Fig. 13.12(c)] > Ctrl+S > OK > File > 

Manage File > Delete Old Versions > Enter > File > Save As > Type >  > Zip File (*.zip) > OK > 
upload the zip file to your course interface or attach to an email and send to your instructor and/or yourself > 
File > Close > File > Exit >Yes  
 

  
Figure 13.12(c) Mounting System Assembly with Temporary Shading (Note that the Datum Features are not displayed) 
 

For additional projects, see www.cad-resources.com > click on the image of your book cover. 
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